User Manual

Tektronix
/

MPEG Test System
Video Stream Analyzer

071-0249-00

This document supports MTS200
MPEG Test System software version 2.5



Copyright© Tektronix, Inc. All rights reserved. Licensed software products are owned by Tektronix or its suppliers and
are protected by United States copyright laws and international treaty provisions.

Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the
Rights in Technical Data and Computer Software clause at DFARS 252.227-7013, or subparagraphs (c)(1) and (2) of the
Commercial Computer Software — Restricted Rights clause at FAR 52.227-19, as applicable.

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this publication supercedes
that in all previously published material. Specifications and price change privileges reserved.

Printed in the U.S.A.
Tektronix, Inc., P.O. Box 1000, Wilsonville, OR 97070-1000
TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.

Microsoft, MS, MS-DOS, Windows, Windows NT, and Win 32 are registered trademarks of Microsoft Corporation.



WARRANTY

Tektronix warrants that the media on which this software product is furnished and the encoding of the programs on the
media will be free from defects in materials and workmanship for a period of three (3) months from the date of shipment.
If a medium or encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange
for the defective medium. Except as to the media on which this software product is furnished, this software product is
provided “as is” without warranty of any kind, either express or implied. Tektronix does not warrant that the functions
contained in this software product will meet Customer’s requirements or that the operation of the programs will be
uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the
warranty period. If Tektronix is unable to provide a replacement that is free from defects in materials and workmanship
within a reasonable time thereafter, Customer may terminate the license for this software product and return this software
product and any associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR
IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX' RESPONSIBILITY TO
REPLACE DEFECTIVE MEDIA OR REFUND CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE
REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX AND ITS
VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF
THE POSSIBILITY OF SUCH DAMAGES.






Y A
Table of Contents

Getting Started

Operating Basics

Reference

Listof Tables . ... ... iii
Preface . ... %
Product DesCription . . .. ... o e 1-1
View WINAOWS . . ..o 1-1
ANAlYSIS. .« o 1-1
First Time Operation. . . . ... e e e e 1-2
Starting the MPEG Video Stream Analyzer. . .. ........ ... ............ 2-1
Functional OVEIVIEW. . . . . .ttt 2-2
Application WINdow. . . .. ... 2-2
View WINAOWS . . ..o e 2-5
MPEG Video Stream Analyzer VIews. . . .. ... 2-7
Main CharacteristicsS VIeW. . . . . ...t e 2—7
Main ViBW . . . e 2-8
Interpreted VIEWS. . .. ..o 2-9
Binary and Hexadecimal Views. . .. ........ ... . ... i 2-11
Decoded Picture VIEW. . . . . ... oo 2-11
AddiNg VIBWS . . oo 2-12
Basic Operations. . . . .. ...t 2-13
Opening VIdeo Streams . . . . ... oot 2-13
Saving Video Streams. . . .. ... 2-15
Analyzing Video Streams . . . .. ... e 2-17
Printing Interpreted VIEWS. . . . ... .. 2-18
Quitting the Application. . . ... ... . 2-19
Menu Selections . . . . ... e 2-19
Interpreted VIeWS . .. ..o 3-1
Interpreted View Window Common Elements. .................... 3-2
SEQUENCE VIBW. . . vttt e e e 3-4
Group of Pictures (GOP) VIEeW. . . . ... .ot e 3-5
PictUre VIeW . . . o 3-6
Slice ViBW . . . 3-8
Additional VIEWS . . . ... 3-9
Binary and Hexadecimal View. .. .. ... i 3-9
Decoded Picture VIEW. . . . ... ..o 3-10

MPEG Video Stream Analyzer User Manual i



Table of Contents

Analyzing Video Elementary Streams . . . ... ... ... oo 3-11
Syntactic AnalysiS . . . .. oo 3-11
Semantic Analysis. . . .. .. 3-14
Automatic Analysis . . ... 3-17
Configuration Reference . . ... ... .. 3-19
Numerical Base . . . . ... 3-19
FONt . o 3-19
Interpretation. . . . ... .. e 3-19
DIrECtONIES. . . o o 3-20
Configuration Files. . . . . ... 3-20
Appendix
Appendix A: Save Video Stream Option Examples . ............. A-1
Index

ii MPEG Video Stream Analyzer User Manual



Table of Contents

List of Tables

Table 2—1: Upper toolbar buttons
Table 2—2: Edit toolbar buttons
Table 2—-3: Main view elements
Table 2—4: Add view options
Table 2-5: Menu selections

Table 3-1: Slice toolbar elements
Table 3—-2: Syntactic analysis tests
Table 3—-3: Semantic analysis tests

MPEG Video Stream Analyzer User Manual



Table of Contents

iv MPEG Video Stream Analyzer User Manual



Y A
Preface

This document supports the MPEG Video Stream Analyzer application.

For information about other MTS 200 Series test system applications, refer to the
user manualprovided with test system. For information about MTS 200 Series
test system hardware installation, specifications, and first-time operation, refer to
theMTS 200 Series MPEG Test System Hardware Installation and Specifications
Manual Tektronix part number 061-4143-0X.

For information about the Windows NT Workstation operating system, refer to
the Microsoft documentation that accompanied your test system.

For information about the Compaq Proliant computer, refer to the Compagq
documentation that accompanied your test system.
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Contacting Tektronix

Vi

Product
Support

Service
Support

For other
information

To write us

For application-oriented questions about a Tektronix measure-
ment product, call toll free in North America:
1-800-TEK-WIDE (1-800-835-9433 ext. 2400)

6:00 a.m. — 5:00 p.m. Pacific time

Or contact us by e-mail:
tm_app_supp@tek.com

For product support outside of North America, contact your
local Tektronix distributor or sales office. You can also call
1-503-627-2400 between 14:00 and 01:00 UTC (GMT).

Contact your local Tektronix distributor or sales office. Or visit
our web site for a listing of worldwide service locations.

http://www.tek.com

In North America:

1-800-TEK-WIDE (1-800-835-9433)
An operator will direct your call.
Tektronix, Inc.

P.O. Box 1000

Wilsonville, OR 97070-1000
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Getting Started

Product Description

View Windows

Analysis

You can use the MPEG Video Stream Analyzer to analyze and save MPEG-1 and
MPEG-2 video elementary streams. You can display MPEG video elementary
stream structures, items, and parameters at different levels using a variety of
secondary windows calladew windows

The following view windows provide high-level views of the video stream:
m  Main Characteristics (see page 2-7)

®  Main (see page 2-8)

m  Decoded Picture (see page 2-11)

The following four view windows, callehterpreted viewsprovide graphical
displays of the video stream syntax:

B Sequence (see page 3-4)

m  Group of pictures (GOP) (see page 3-5)
m  Pictures (see page 3-6)

m  Slice (see page 3-8)

All of the interpreted views are interactive in ways that make it easy for you to
analyze the structures of the elementary stream.

Finally, you can view the bitstream of the video elementary stream in binary and
hexadecimal formats using the Binary or Hexadecimal view windows.

From the Interpreted, Binary, and Hexadecimal view windows, you can perform
a syntactic analysis of the active MPEG structure. From the Main and Decoded
Picture view windows you can also perform a semantic analysis on the complete
video stream. Segnalyzing Video Elementary Streaorspage 2—17 and

Analyzing Video Elementary Streaorspage 3—11 for more information on
performing syntactic and semantic analyses.
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Getting Started

Limitations

First Time Operation

1-2

The MPEG Video Stream Analyzer does not perform a syntactic analyses on the
following MPEG-2 structures:

m  Macroblock

m  Macroblock modes
®m  Motion vectors

m  Motion vector

m  Coded block pattern
®  Block

The MPEG Video Stream Analyzer is part of a suite of hardware and software
components used to create, generate, aquire, and analyze MPEG and DVB
transport and program streams. Before you can use the analyzer, you need to
ensure that you have entered the correct password for your software configura-
tion. To enable the test system configuation you have purchased, use the
procedure for entering the general password described MRE® Test System
Software MTS2ES, MTS2AN, MTS2CR, and MTS2TS Installation Manual

NOTE. If you have already performed the procedure described in the installation
manual, you do not need to perform it again.

MPEG Video Stream Analyzer User Manual
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Operating Basics

Operating Basicss organized into the following sections:

m  Starting the MPEG Video Stream Analydescribes how to start the
analyzer using standard Windows NT techniques.

m  Functional Overvievdescribes the application window types and the
application interface elements.

®  MPEG Video Stream Analyzer Viedescribes the views used by the
application and how to access them.

m  Basic Operationslescribes common procedures used to display, analyze,
and decode video stream files.

®m  Menu Selectionsummarizes the menu selections.

NOTE. For basic Windows operating techniques such as, minimizing windows or
using the scroll bars, refer to your Windows documentation.

Starting the MPEG Video Stream Analyzer

Double-click the MPEG Video Stream Analyzer icon in the MPEG Test
System program group window.

“ideo Stream
Analyzer

MPEG Video Stream Analyzer User Manual 2-1
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Functional Overview

The MPEG Video Stream Analyzer uses two window types to display video
elementary streams: an application window and secondary windows called view
windows.Functional Overviewdescribes the characteristics of these windows.

Application Window  When you first open a video elementary stream, the application window opens
and looks similar to the following illustration.

Title bar — IR Analyzer
Menu bar —— File Edit Selection gAnalysis Options ‘window Help

Upper toolbar —— 285 | Bl

Edit toolbar ——» < 2 )

Status bar — |

The following sections describe the elements of the application window.

Title Bar. The title bar displays the application name and application icon. The
window control buttons are standard window controls and allow you to
minimize, maximize, and close the application window.

2-2 MPEG Video Stream Analyzer User Manual
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Menu Bar. The menu bar provides access to the commands you use to control the
display, analysis, and look of the MPEG Video Stream Analyzer. A list of menu
selections is provided iMenu Selectionbeginning on page 2—-19.

Upper Toolbar. The Upper toolbar provides shortcut buttons to five commonly
used menu selections. These buttons, and the menu selections they represent, are
described in Table 2-1.

Table 2-1: Upper toolbar buttons

Button | Name Description
5‘_@| Open Displays the Open dialog box. Selecting this button is the
same as selecting Open from the File menu (see
page 2-13).
E Save as Displays the Save As dialog box. Selecting this button is the
same as selecting Save As from the File menu (see
page 2-15)

Main view Displays the Main view window for the active video stream.
Selecting this button is the same as selecting Main view
from the Selection menu (see page 2-8).

! Add view Displays a submenu from which you specify a view to be
displayed. Selecting this button is the same as selecting
Add view from the Window menu (see page 2-12).

LTl Main characteristics | Displays the Main Characteristics window for the active
view video stream. Selecting this button is the same as selecting
Main characteristics from the Selection menu (see

page 2-7).

MPEG Video Stream Analyzer User Manual 2-3
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Edit Toolbar. The Edit toolbar provides shortcut buttons to selections found in the
Edit menu. These buttons, described in Table 2—2, allow you to move through
the items (decoded picture, sequence, GOP, or picture items) of the active view
and to view the errors in the video stream file. More complete descriptions of
these buttons are provided in tklenu Selectionsection beginning on page

2-19 where the Edit Menu selections are described. (The button descriptions are
the same as the menu selection descriptions.)

Table 2-2: Edit toolbar buttons

Button | Name Description

ﬁl First Displays the first item in the active view. Selecting this button is
the same as selecting First from the Edit menu.

il Previous Displays the previous item in the active view. Selecting this
button is the same as selecting Previous from the Edit menu.

_?| Goto Displays a dialog box that allows you to select the item number
of the active view you want displayed. Selecting this button is
the same as selecting Go to from the Edit menu.

_>| Next Displays the next item in the active view. Selecting this button is
the same as selecting Next from the Edit menu.

ﬂ' Last Displays the last item in the active view. Selecting this button is
the same as selecting Last from the Edit menu.

Number of Items | Counts the number of items in the element and displays the
number at the top of the interpreted view. Selecting this button is
the same as selecting Number of Iltems from the Edit menu.

ﬂ Next error Displays the next item that has an error in the video stream file.
Selecting this button is the same as selecting Next error from
the Edit menu.

Status Bar. The Status bar, located just below the Edit toolbar, provides you with
first level help on using the menus. As you highlight a menu item, the status bar
describes the menu selection.

W4 2] ¥

Dizplay the main characteristics of the video sequence
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View Windows  View windows display the syntax of the elementary stream at different levels.

Application
window

View
window

The following illustration show the Main view window and the application
window.

*MPEG Video Stream Analyzer

“t5Main view -» doncarlo.vid
Ttem SH 1 Ttem GOP 1

Sequence | Sequence | Extension Group of
pictures
header eREtEnson header

extension

M4 2] »d L
r -~

Common View Window Elements. In addition to standard window controls, the
title bar of the view windows provides the following information:

m  View type. The view type indicates the type of view displayed in the view
window.

m  File name. The file name indicates the name of the video stream file or the
transport stream from which the video stream was extracted.

NOTE. If you maximize the view window, the view type and file name are
displayed in the title bar of the application window.

MPEG Video Stream Analyzer User Manual 2-5
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The top line of the Main and interpreted view windows provides the following
information (refer to the illustration below):

m  View type. The view type indicates the type of view displayed (Main,
Sequence, GOP, or Picture).

m [tem. The item indicates which item of the viewed syntax is displayed. From
the Main view window, you can display the total number of items in each
structure by performing one of the following operations:

m  Click the Number of Items command button from the Edit toolbar (see
page 2-4).

m  SelectNumber of Iltems from the Edit menu.

The Number of Items message window is then displayed, indicating the total
number of Sequences and GOPs in that structure for the active video stream.

Number of Items

@ Main view > doncarlo. vid

Mb of ltems [ Sequences + Gops | = B3

The total number of items in each structure is displayed in the top line of the
view window as shown in the following illustration.

Main view -> doncarlo. vid M=l E
Ttem SH 1/1  Ttem GOP 1/68 2]
‘ Sequence | Sequence | Extension Group of
and wictures

In the interpreted views, the item number provided is the number of items in
the displayed structure. For instance, if you were to double-click the GOP
rectangle, the top line of the GOP interpreted view window would look
similar to the following illustration.

Group of pictures Yiew -> doncarlo_vid [_ (O]
Group of pictures Ttem 17468 :I

Drop
ame flag]

Group
start code

Mlarker
bit

Closed
2op

Broke
link:

Time code
pictures

Time code
seconds

Time code
mitutes

Tine
code
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The areas of the view windows below the top line are described briefly in
MPEG Video Stream Analyzer Viewlse next section, and more thoroughly
in theReferencesection of this manual.

MPEG Video Stream Analyzer Views

You can use the MPEG Video Stream Analyzer to view elementary video
streams at different levels. This section briefly describes these views and how to
access them. Séwterpreted Viewseginning on page 2-9, and gaditional
Viewsbeginning on page 3-9 for more detailed information about the various
view types used by the analyzer.

Main Characteristics View  When you open a new video elementary stream, the Main Charactefiestics
window is automatically displayed if the elementary stream includes a sequence
header.

NOTE. Because the main characteristics of the stream are read in the first
sequence header of the stream, if the stream does not contain a sequence header,
the Main Characteristics view window is not displayed and is not available from
any other view window. The requirement for a sequence header also means that

if a video stream is opened as a Sequence, GOP, or Picture document file type
(seeOpening Video Streamsn page 2—13), the Main Characteristics view

window will not be available.

The Main Characteristics view window allows you to quickly access basic
information about the video stream.

[ doncarlo.vid

MAIN CHARACTERISTICS
“MPEGZ stream |

Horizontal siza 04 samplas
Wartinal sime 576 lines
Aspect ratio information reserved
Frame rate 25000 pictures/s
Bit rate 5400 000 Bitis)fs
VEV Buffer size 0 Eit(s)
Profile Mlain
Level Main
Progressive sequence all types of pictures
Chroma fornmat 4:2:0
Video format unspecified
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2-8

Main View

Display the Main Characteristics view window from any of the other view
windows by clicking the Main Characteristics button on the Upper toolbar (see
page 2-3), or by selectimdain Characteristics from the Selection menu.

When you open a video elementary stream as a Video Stream file type (see
Opening Video Streanm page 2—13), the Main view window is displayed. The
Main view is interactive and allows you to display specific video stream syntax
for further analysis.

NOTE. To display the Main view window, the video stream must include a
sequence header. You can open a video stream that does not have a sequence
header by opening the file as a Sequence, GOP, or Picture document. See
Opening Video Streanmsn page 2—13.

Display the Main view window from any of the other interpreted view windows
by clicking the Main View button on the Upper toolbar (see page 2-3), or by
selectingMain View from the Selection menu.

Main view -> doncarlo.vid

Tten SH 1 Ttern GOP 1 =
Secquence | Sequence | Estension Group of
and pictures
header extension users header

Picture 1 (I, Frame picture, )

Picture Picture Picture
coding
header extension data
Picture 2 (P, Frame picture, 3) Picture 3 (B, Frame picture, 1) Picture 4 (B, Frz
Picture Picture Picture Picture Picture Picture Picture Pich
coding coding codi_
- . L . _ _’I_JI

The different elements of the displayed video stream are represented by
rectangles. Each rectangle displays some minimal information about the
structures of a sequence, GOP or picture. For example, in the illustration above,
the sequence structure consists of a sequence header, sequence extension, and
user data.

Table 2-3 lists the video stream elements displayed in the Main view window.
Double-click the rectangles to access more detailed interpreted views for the
structures indicated. (The page numbers in parentheses indicate where the
interpreted view for each structure is discussed in this manual.)
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Table 2-3: Main view elements

Element rectangle Video stream element
Sequence | Sequence | Extension Sequence (page 3_4)
and
header extension users
Group of GOP (page 3—5)
pictures
header
Picture 1 (I, Frame picture, 0) Picture (page 3-6)
Picture Picture Picture
coding
header erEtension data

The gray title bar in the Picture rectangles indicates the picture number, coding
type (I, P or B), structure (field or frame for MPEG-2 streams), and the temporal
reference of the picture.

You can display the Main view window without the detail in the rectangles by
selectingCut Down/Blow up Main View from the Window menu, or by
pressing thé&3 function key.

Interpreted Views  To access a graphical view of an MPEG structure, double-click one of the
rectangles associated with the structure you want to display from the Main view
window. The resulting display is called an interpreted view. Using interpreted
view windows, you can display a representation of the following MPEG-1 and
MPEG-2 video stream structures and perform syntactic analyses on these
structures:

m  Sequence structures

®  Group of Pictures structures
m  Pictures structures

m  Slice structures

Like the Main view window, interpreted view windows are interactive. Each
interpreted view displays the values found in different MPEG structures for the
active video stream. Each field is named and represented by a large rectangle;
each value is displayed in a small rectangle just below the large named rectangle.
(See the following illustration of the Sequence view window.)

MPEG Video Stream Analyzer User Manual 2-9
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+m Sequence Yiew -> doncarlo_vid

e 3

Sequence ||Honzontal || Vertical | |[Aspect rato| [SEEll | Bit rate | (Marker|| Vhbw buffer || Const
header code| | size walue | | size value | | information | fei st | value bit size value parar

fl
EREEEEE . B
25 12 —{r— ) This is a four-bit integer used to .
Extension | Extension starf] | Profile and | [Progress: define frame rate value. Bit rate
start code | [code identifier lewel SECUENCE T TOTIET e FETETISION | | EXtEnsion
mndication extension
Laz L v J[ e [ o JL o o J[ o J[ o
ha— ) — ! 8 — — —12—
Tser data || User
start code data
434 40
—32— A
< | H

Double-click a large rectangle to display a description of the field. You can move
the displayed message box anywhere within the view window. To move the
message box, click and drag the title bar. Dismiss the message box by clicking
anywhere outside of it.

Double-click a small rectangle to display an interpretation of the value for that
field. Dismiss the message box by clicking anywhere outside of it.

‘= Sequence View -3 doncarlo_vid

e 1 3

Sequence ||Heonzontal || Vertical | |[Aspect ratio| | Frame || Bitrate | |MMarker|| Vb buffer || Const
header code| | size value | | size value | | information | |rate code|| walue bit size value patrat

TEC (NN M (| | I I |

eV el Vel Vo — ‘—4—>| Frame rate value: 25 ]— «——]0—— «——

Extension | [Extension starf] | Profile and | [Progresstve[ [ Chtotna || Hotizontal | [Vertical size| | Bit rate
start code | |code identifier lewel secuence || format size extension | |extension
indication extension
Les J ¢ J 72 L o J[ 1 J[ o J[ o J[ o
p— Y — <} 3 2 — 12—

Tzer data (|| Tser
start code data

434 40

4—32—1‘

1] | a7
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Interpreted view windows can also display the position or the length of the field
in the bitstream. When enabled, this information is displayed below the small
rectangles. Select which type of information, if any, you want to display using
the following procedure:

1. Selectinterpretation from the Options menu, and then select one of the
following options:

m  Positionindicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

m  Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.

Binary and Hexadecimal ~ You can use the Binary and Hexadecimal view windows to view the bitstream of
Views  the video elementary stream for the active MPEG structure. Access the Binary
and Hexadecimal views using the following procedure:

1. Navigate to the interpreted view window for the structure you want to
analyze.

2. Select the Add View button on the Upper toolbar (see page 2-3), and then
selectBinary or Hexadecimalfrom the submenu. Alternatively, you can
selectAdd View from the Window menu, and then selBatary or
Hexadecimalfrom the submenu.

The characteristics of the Binary and Hexadecimal view are descriBéohbiry
and Hexadecimal Viewn page 3-9.

Decoded Picture View  The picture displayed under the Sequence rectangle in the Main view window (if
decoded) corresponds to the first I-picture of the group of pictures. This picture
is decoded using only the DC coefficients of the macroblocks. Double-click the
picture to display the Decoded Picture view window. The resulting picture is
decoded using all of the coefficients.

NOTE. The Decoded Picture view window is a visualization tool, not an analysis
tool.

MPEG Video Stream Analyzer User Manual 2-11
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Adding Views

You can add multiple view windows to the application window using one of the
following techniques:

m  Select the Add View button from the Upper toolbar (see page 2-3), and
then select the type of view window you want displayed from the submenu.

m  SelectAdd View from the Window menu, and then select the type of view
window you want displayed from the submenu.

The views available from the submenus in both cases depend on the active view
window as described in Table 2—4.

Table 2-4: Add view options

From this view window Select Add View to display

Main view ®  An additional Main view or
m A Decoded Picture view

Interpreted view ®m  An additional interpreted view or
m  ABinary or Hexadecimal view

Binary or Hexadecimal view ®  Aninterpreted view of the syntax or
m A Binary or Hexadecimal view

Decoded Picture view m A Main view or
m  An additional Decoded Picture view

MPEG Video Stream Analyzer User Manual
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Basic Operations

This section describes how to open, save, print, and analyze MPEG video stream
files and how to exit the application.

Opening Video Streams ~ The MPEG Video Stream Analyzer displays the following video elementary
stream types:

m  MPEG-1 and MPEG-2 elementary video stream files

®m  Video elementary streams extracted from an MPEG transport stream

NOTE. The MPEG Video Stream Analyzer cannot analyze a file containing both
MPEG-1 and MPEG-2 video streams.

Opening elementary video stream files. To open a video stream file, use the
following procedure:

1. Click the Open button on the Upper toolbar (see page 2-3), or ©gent
from the File menu.

2. Select the appropriate file from the Open dialog box.

3. From thelList files of type drop down selection box, select the type of
document you want to open the file as, and then select OK.

Open H
File: harme: Folders: -D K
Ix_x c:hmts2004wvideo\525

Cancel
dancarlo. vid ;l =t ;I —l
MOBL_015.MP2 = MT5200
MOEL_0E0.MP2 = VIDED
B 525
20 TESTRAT
List files of type: Dirives:
Yideo Stream j I ==, j Metworlk, .. |

SEQUENCE documnents
GOP documents
PICTURES documents
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The following list describes how each of thiet files of type options affects
how the elementary stream file is opened:

NOTE. Files opened using the Video Stream option display only those items that
come after the first sequence header in the bitstream. Files opened using either
the GOP and Picture document options display all of the GOPs and Pictures in
the file regardless of whether the file has a sequence header. Consequently, files
opened using one of the latter options may allow you to view GOPs and Pictures
you otherwise could not.

m  Video Stream.When a video stream file is opened using this option, the
Main Characteristics and Main view windows are displayed. Only files that
have a sequence header can be opened using this option.

m  SEQUENCE documentsWhen a video stream file is opened using this
option, the Sequence interpreted view window is displayed.

m  GOP documentsWhen a video stream file is opened using this option, the
Group of pictures interpreted view window is displayed.

m  PICTURES documents.When a video stream file is opened using this
option, the Pictures interpreted view window is displayed.

If you open a video stream as a Pictures document and the file contains no
sequence header, the MPEG Video Stream Analyzer uses default interpreta-
tion parameters to display the file. In this case, you will see a message
indicating that some of displayed parameters could be false.

Opening video streams extracted from a transport stream. To open and analyze an
elementary stream that is extracted from a transport stream file, use the following
procedure:

1. Confirm that you know the PID of the packets that contain the video stream
of interest. If necessary, examine the transport stream first with the Tektronix
Deferred-Time Analyzer application.

2. SelectOpen from the File menu.
3. Select the appropriate file from the Open dialog box.

4. Enter the PID of the packets that contain the video stream.

NOTE. You can open the MPEG Video Stream Analyzer with an elementary video
stream directly from the Tektronix Deferred-Time Analyzer. From the Hierarchic
View, right-click the video elementary stream icon and s®deio Stream
Analyzerfrom the submenu.
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Saving Video Streams  Use the following procedure to save all or part of a video stream to a file. (See
Appendix A: Save Video Stream Option Examfaleexamples of how the
different Save as dialog box options work in different scenarios.)

NOTE. Because you can save video streams only from the Main view window,
only those sequence headers, GOPs, and pictures after the first sequence header
can be saved to a new video stream file.

1. Navigate to the Main view window, and then click the Save as button on the
Upper toolbar (see page 2-3), or sefemte Asfrom the File menu.

The displayed dialog box allows you to select which part of the active video
stream you want to save. The default settings are shown in the following
illustration.

@Save Yideo Skream -» doncarlo.vid

Fiepetition Caunt

£ | Picture |1 |1

£ From picture |1 to picture |1
 From GOP |1 to GOP |1 ¥ Sequerce Header

 Fram |1 milizeconds ta I1 millizeconds ¥ Sequence End

| 0%

ak I Cancel

2. Choose the portion of the elementary stream you want to save by selecting
one of the following options:

m  All the video stream.Use this option to save the entire displayed video
stream; that is, all sequence headers, GOPs, and pictures.

NOTE. For the following options, if a sequence header immediately precedes the
GOP, the sequence header is automatically saved.

m |-Picture. Use this option to save the indicated I-Picture and the GOP
associated with it.
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®  From picture. Use this option to save the indicated range of pictures.
The saved portion of the stream begins with the @D&wing the
picture indicated in thErom picture text box and includes the GOP of
the picture indicated in the picture text box, with the following two
exceptions:

m |f the picture indicated in thEérom picture text box is the first
picture in any GOP, then the stream is saved beginning with the
GOP of the picture, not the following GOP.

m [f the indicated pictures are in the same GOP, then that GOP is
saved.

m  From GOP. This option allows you to save the indicated range of
groups of pictures.

®  From. This option allows you to save the indicated time segment of the
video stream. Time is indicated in milliseconds. This option uses the
same criteria as tHerom picture option.

NOTE. All of the text boxes in the Save as dialog box must include a value
greater than 0. Blank text boxes, or text boxes with out of range values are
flagged as errors. If a blank text box, or out of range value is detected, an error
message is displayed indicating the correct range of values. To continue saving
the video stream, you must first enter a valid value in the text box.

3. If you have selected an I-picture, a range of pictures or GOPs, or a time
segment, enter the |-picture number or the appropriate valuesHnattme
andto text boxes.

4. Enter theRepetition Countto specify the number of times the stream
segment is repeated in the new file. All repetitions greater than one are
appended to one another in the new file.

NOTE. Ensure that the first saved GOP is preceded by a sequence header. If you
do not, you will be unable to open a Main view window of the saved stream later.

5. Choose &equence Headeand/or &Sequence Endf appropriate. Choose
Sequence Headeif the selected picture(s) or GOP(s) are not immediately
preceded by a sequence header. The new file will use the first sequence
header found in the source stream.

6. When all of the necessary information has been entered @Kc¢kand a
standard Save aBalog box is displayed.

7. Select an appropriate drive, directory, and file name from the Save as dialog
box, and then cliclOK.
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NOTE. You cannot save video streams to the Tektronix MPEG Test System Data
Store directory, C:\CarbO.

8. A progress bar is displayed to indicate the status of the operation. Click
cancel to stop the process, or you can press the Esc key on your keyboard.

@ Save Yideo Stream -> doncarlo.vid M=
&) & the viden stream Fepetition Caurt
[ Picture I‘I— |1
= Fram pisture I‘I— to picture I‘I—
£ From GOF I‘I— to GOE I‘I— I¥| Sequence Headzr
! Fram I‘I rillizecands o I‘I millizecands ¥ | Sequence End

S D & TR Eak S WA B S TS0 BN S EE s ample yvid

SAVE ALL THE VIDEO STREAM...
PUSH THE CANCEL BUTTON TO ABORT.

When the Save as process is finished, a message box is displayed indicating that
the new file has been saved successfully.

Analyzing Video Streams  You can use the MPEG Video Stream Analyzer to check MPEG encoded video
streams for syntactic and semantic errors.

Syntactic Analysis. Syntactic errors indicate errors in the values of the MPEG
structures.

To perform a syntactic analysis, use the following procedure:

1. Navigate to the interpreted view of the element in the elementary stream that
you want to check.

2. SelectSyntactic from the Analysis menu.

3. The analyzer performs a syntactic analysis of the element you have selected
and reports errors in an error message window.

4. Each line in the error message window represents a syntax error. Double-
click an error message and the interpreted view window containing the error
is displayed with the value in error displayed in red.
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You can perform a syntactic analysis on all of the structures in the video stream
by navigating to the Main view window, and then performing the analysis. See
Syntactic Analysisn page 3—11 for more information about how the MPEG
Video Stream Analyzer performs syntactic analyses.

Semantic Analysis. Semantic errors indicate errors in the MPEG structure when
compared to the standard.

To perform a semantic analysis, use the following procedure:
1. Navigate to the Main view window.
2. SelectSemanticfrom the Analysis menu.

3. The analyzer performs a semantic analysis of the video stream and reports
errors in an error message window.

4. Each line in the error message window represents a semantic error. Double-
click an error message and the interpreted view window showing the syntax
in error is displayed. Semantic errors are not displayed in red.

Semantic analyses can be performed only from the Main view window. See
Semantic Analysisn page 3—-14 for more information about how the MPEG
Video Stream Analyzer performs semantic analyses.

With the MPEG Video Stream Analyzer, you can print any of the view windows
except the Main Characteristics and Decoded Picture view windows. To print the
information displayed in a view window, use the following procedure:

1. Set up the page layout by selectiPrnter setup from the File menu, and
then make the appropriate selections for paper size and source, orientation,
and margins from the Page Setup dialog box.

2. Set up the printer connections by selectingRhiater command button, and
then making the appropriate printer and printer properties selections (see
your Windows documentation).

3. Return to the view window you want to print and seRratt from the File
menu.

4. The Print dialog box is displayed. Make standard Windows Print selections
and print the contents of the active view window.
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Quitting the Application

To quit the MPEG Video Stream Analyzer, selexit from the File menu.

To close a window without exiting the analyzer application, use one of the

following techniques:

m  To close an active view window, select the close button on the active view
window. Alternatively, seledClose viewfrom the Window menu.

m  To close all windows, sele€@lose allfrom the Window menu.

Menu Selections

Table 2-5 summarizes each of the menu selections for the MPEG Video Stream

Analyzer.

Table 2-5: Menu selections

Menu Selection Description
File Open Displays the Open dialog box from which you identify
the existing video stream file you want to view.

Save as Displays the Video Stream Save dialog box from
which you indicate how much of the file you want to
save. After you select OK, a standard Save As dialog
box is displayed.

Print Displays a standard Print dialog box from which you
can print the active view window.

Printer setup Displays the Page Setup dialog box from which you
specify the paper size, orientation, and page
margins. The dialog box also provides access to
printer options.

Exit Quits the MPEG Video Stream Analyzer.

Edit Next Displays the next item in the active view.

Previous Displays the previous item in the active view.

First Displays the first item in the active view.

Last Displays the last item in the active view.

Goto Displays the specified item in the active view.

Number of Items

Calculates the number of items in the active view,
and displays the number in the upper portion of the
active view window.

Next error

Displays the next item in the active view with a
syntactic error.
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Table 2-5: Menu selections (cont.)

Menu Selection Description
Selection | Main Characteristics Displays the Main view window for the video stream
file indicated in the title bar of the view window.
Main View Displays the Main Characteristics view for the video
stream file indicated in the title bar of the view
window.
Analysis | Syntactic Performs a Syntactic analysis on the video stream

file indicated in the title bar of the secondary window.
See page 3-11.

Semantic Performs a Semantic analysis on the video stream
file indicated in the title bar of the secondary window.
See page 3-14.

Automatic Performs the analyses you select using the Options
for automatic analysis dialog box See page 3-17.
Options Cut Down/Blow up Toggles the Main view window between a detailed
Main View view and one that is less detailed. The F3 function

key also toggles between these types of views.

Base Displays the Base dialog box from which you set the
numeric base (decimal or hexadecimal) you want to
use for various interpreted views.

Font Displays the Font dialog box from which you set the
font you want to use for various views.

Directories Displays the Default Directories dialog box. You
select the directories to which the MPEG Video
Stream Analyzer messages and configuration files
are saved.

Automatic Analysis Displays the Options for automatic analysis dialog
box from which you indicate the types of analyses
performed when you select Automatic from the
Analysis menu. You can choose any combination of
the two options. The default is to perform both
syntactic and semantic analyses.

Interpretation Displays the Interpreted view option dialog box from
which you can choose to display either the length or
the position of the structures in the interpreted views.

Read configuration Displays the Read Configuration dialog box from
which you can load an existing configuration file into
the MPEG Video Stream Analyzer.

Save configuration Displays the Save Configuration dialog box from
which you can save the current configuration into a
specified configuration file.

Set default configuration | Loads the default configuration file into the MPEG
Video Stream Analyzer.
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Table 2-5: Menu selections (cont.)

Menu Selection Description

Window | Cascade Displays the open view windows on top of one
another.

Tlle Fits the open view windows to the application
window.

Arrange icons Arranges all minimized windows to the bottom of the
application window.

Close view Closes the selected view window.

Close all Closes all of the view windows.

Add view Displays a submenu from which you can choose to
add an identical view of the selected view or a
different view of the displayed information. Same as
the Add View button on the upper toolbar.

List of open view Selects the active view from the listed view windows

windows and brings the selected view to the front of the
display. All open views are listed, including any
minimized windows. A checkmark indicates the
current active view.

Help Contents Displays the MPEG Video Stream Analyzer Help
contents from which you can choose or search for a
specific help topic

Using help Displays the Windows Help contents.

About MPEG Video Displays version number and copyright information

Stream Analyzer about the MPEG Video Stream Analyzer.
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Referencerovides detailed information about the MPEG Video Stream
Analyzer. This chapter is organized into the following sections:

®  Interpreted Views

®m  Additional Views

®  Analyzing Video Elementary Streams
m  Configuration Reference

Commonly performed procedures, view window descriptions, and common
interface elements are describe®iperating Basics.

Interpreted Views

The MPEG Video Stream Analyzer uses four interpreted views to display the
elements of MPEG-1 and MPEG-2 encoded video streams:

m  SequenceThis view window displays elements described by the video
sequence structures of MPEG-1 and MPEG-2 encoded video streams.

m  Group of pictures (GOP). This view window displays elements described
by the GOP structures of MPEG-1 and MPEG-2 encoded video streams.

®m  Picture. This view window displays elements described by the picture
structures of MPEG-1 and MPEG-2 encoded video streams.

m  Slice.This view window displays elements described by the slice structures
of MPEG-1 and MPEG-2 encoded video streams.

Each of the interpreted view windows are interactive and have some common
interface elements. These common elements are described in the next section,
Interpreted View Window Common Elemeiitse following sections describe

each of the interpreted views in more detalil.
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Interpreted View Window
Common Elements

Each interpreted view window uses a series of rectangles to represent the fields
and values associated with specific MPEG video elementary stream structures.

Shaded rectangles are used to highlight more important or critical fields and
values of MPEG elementary streams. The following illustration of the Sequence
view window shows the elements that all interpreted view windows have in

common.

‘= Sequence Yiew -> doncarlo.vid

Sequence ||Henzontal || Vertical | |[Aspectratio|| Frame ||Bitrate | (MMarker|| Wby buffer || Const
Row of — header code| | size value || size value | | information | |rate code || walue bit size value parat
rectangles il
435 || 704 ][ 56 [ 8 || 3 Jlmsool 1 ][ o ][
R e P — ] — ) =) 1= e—]——r e—— ] ——
Extension | [Extension startl | Profile and | [Progressive|| Chrotna | | Horizontal | [Vettical size| | Bit rate
Large rectangles —— start code | |code identifier lewel sequence || format sige extension | |extension
indication extension
Small rectangles —>| 437 | | 1 | | 72 | | 0 | | 1 | | 0 | | 0 | | ]
Y ) 8 — ]2 — —l2—
Tser data User
statt code data
434 40
Length/Position ——s——32——

indicator 1 |

4

In addition to the common elements for the MPEG Video Stream Analyzer view
windows (se€Common View Window Elemerais page 2-5), the preceding
illustration shows the following elements common to interpreted view windows:

Row of rectanglesEach row in an interpreted view window represents a

structure in the displayed element. For instance, the first row of the

preceding illustration represents the sequence_header() structure; the second
row represents the sequence_extension() structure, and the third line
represents the extension_and_user_data() structure.

Large rectangles.The large rectangles represent specific fields in the

structure of the displayed element. For instance, in the preceding illustration,
the large rectangle, Horizontal size value, represents the
horizontal_size_value field.

Double-click a large rectangle to display a description of the field. You can
move the message box to make it easier to read by clicking and dragging the
title bar of the message box. Dismiss the message box by clicking anywhere

outside of the box.

3-2

MPEG Video Stream Analyzer User Manual



Reference

m  Small rectangles.The small rectangles represent the values encoded in the
bitstream for the fields.

Displayed values can be shown in decimal or hexadecimal base. To toggle
between the two, press the function key. (You can also seldgasefrom

the Options menu, and then make the selection from the dialog box.) Red
values indicate syntax errors.

Double-click a small rectangle to display an interpretation of the value.
Dismiss the message box by clicking anywhere outside of the box.

m | ength/Position indicator. Interpreted views can display the position or the
length of the fields. When enabled, this information is displayed below the
small rectangles. You determine which type of information, if any, is
displayed using the following procedure:

1. Selectinterpretation from the Options menu, and then select one of the
following options:

m  Positionindicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

m  Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.

You can use the Edit toolbar to navigate through the displayed items from all of
the interpreted view windows. Seelit Toolbaron page 2—4 for more informa-
tion about the Edit toolbar.

You can also display a Binary or Hexadecimal view window from any inter-
preted view window using one of the following methods:

m  Click the Add view button, and then select eitBarary or Hexadecimal
from the submenu.

m  SelectAdd view from the Window menu, and then select eitBierary or
Hexadecimalfrom the submenu.
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Sequence View  To access the Sequence interpreted view window, double-click the large

Sequence Header rectangle from the Main view window.

Extension
and
users

Secquence | Sequence

header extension

You can also access the Sequence interpreted view window by opening a video
stream as &equence documentiile type. Se€pening Video Streanus
page 2-13.

Seelnterpreted Viewsn page 2-9 aniditerpreted View Window Common
Elementon page 3-2 for information about interpreted view windows and how
to use the interface elements.

‘= Sequence Yiew -> doncarlo. vid

T 1 =
Sequence ||Honzontal || Vertical |[Aspectratio|| Frame ||Birate | |Marker|| Viw buffer || Const
header code|| size value || size value | | mformation | |rate code|| value bit size value patat
fl
435 | 704 ][ 576 || & || 3 |[mseo| 1 || o ||
Extension | [Extension start| | Profile and | [Progressive| | Chroma || Horizontal | [Vertical size| | Bit rate
start code | |code identifier level sequence || format SIZE extension | | extension
mdication extension
a | v [ 72 [ o L1 f[ o [ o [ o
i — =) 8 e — —12—
Tser data || User
start code data
434 40
50— bt
1| | Ay

If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

The Sequence interpreted view may display the following structures:

m  Sequence Header

B Sequence Extension

®m  Sequence Display Extension
m  Sequence Scalable Extension
m  User Data
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Double-clicking the value rectangle (small rectangle) of the quant matrixes
(which can be present in either the sequence header or in the quant matrix
extension) displays the quant matrix.

Hon Intra Quantiser Matrix

Double-click the large User data rectangle to display either a binary or hexade-
cimal view of the sequence structure. The value displayed in the small User data
rectangle indicates the number of data bytes.

Group of Pictures (GOP)  The GOP interpreted view displays the GOP header structure. To access the GOP
View interpreted view window, double-click the large GOP rectangle in the Main view
window.

Group of
pictures
header

You can also access the GOP interpreted view window by opening a video
stream as &0OP documentsfile type. Se@pening Video Streanm
page 2-13.

NOTE. If you display the GOP interpreted view window from the Main view
window, only the GOP structures that follow the first sequence header are
displayed. None of the GOPs located before the first sequence header are
displayed. To display all of the GOPs before the first sequence header, open the
file as aGOP documentsile type.

Seelnterpreted Viewsn page 2-9 aniditerpreted View Window Common
Elementon page 3-2 for information about interpreted view windows and how
to use the interface elements.
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Picture View

Emup of pictures ¥iew -> doncarlo.vid

tom 2 =
Group Drop Time | |Tine code| |MMarker| | Time code| [Tine code|| Clozsed | |Broke
start code| frame flag| | code mirmites bit seconds pictures gop link:
hours
L440 J[ o J[ o JL o Lol o JL o J[ol]leo
4 | E v/

If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

To access the Picture interpreted view, double-click the large Picture rectangle in
the Main view window.

Picture 1 (I, Frame picture, 0)

Picture Picture Picture
coding
header extension data

You can also access the Picture interpreted view by opening a video stream as a
Picture documentsfile type. Se€pening Video Elementary Streaorspage
2-13.

NOTE. If you display the Picture interpreted view window from the Main view
window, only the Picture structures that follow the first sequence header are
displayed. None of the pictures located before the first sequence header are
displayed. To display all of the pictures before the first sequence header, open
the file as aicture documentdile type.

Seelnterpreted Viewsn page 2-9 aniditerpreted View Window Common
Elementon page 3-2 for information about interpreted view windows and how
to use the interface elements.
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If the video stream was extracted from a transport stream, the PID of the
elementary stream is displayed in the title bar of the view window.

The Picture interpreted view may display the following picture structures:

®m  Picture header

®  Picture coding extension

®  Quant matrix extension

®  Picture display extension

m  Copyright extension

m  Picture spatial scalable extension

m  Picture temporal scalable extension
m  Picture data

Double-click the large Picture data rectangle to display the Slice view, which is
described in the next section. The small Picture data rectangle indicates the
number of data bytes for the picture data.

MPEG Video Stream Analyzer User Manual 3-7



Reference

Slice View  To display the Slice interpreted view, double-click the large Picture data
rectangle in the Picture interpreted view window.

gPiclure View -> doncarlo.vid :2

Picnre 2 (Bt el 4 ol SE

Slhice start] | Quantiser | (Estra bit
code ||scale code slice

4] | Mz

You can also display the Slice view from the Picture view using one of the
following methods:

m  Click the Add View button on the Upper toolbar (see page 2-3), and then
selectSlice Viewfrom the submenu.

m  SelectAdd View from the Window menu, and then sel8tte Viewfrom
the submenu.

The look and use of the Slice view is similar to the other interpreted views.
However, the Slice view window provides an additional toolbar that you use to
navigate through the slices of the displayed picture. The current picture is
indicated in the top line of the view window. Table 3-1 describes the Slice
toolbar elements.

Table 3-1: Slice toolbar elements

Element Name Description
s Slice number | Indicates which slice of the current picture is displayed.
= First Displays the first slice of the current picture.
i Previous Displays the previous slice of the current picture.
2] Goto Displays the slice of the current picture that you indicate.
31 Next Displays the next slice of the current picture.
31 Last Displays the last slice of the current picture.
Number of Displays the number of slices of the current picture. The total
items number of slices is then displayed in the Slice number element.
¥ Next Error Displays the next slice of the current picture that contains at
least one syntactic error.
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Additional Views

Binary and Hexadecimal
View

The MPEG Video Stream Analyzer provides different ways of looking at the
video bitstream using the views described in this section: Binary, Hexadecimal,
and Decoded Picture views. The interactive characteristics of these view
windows are limited and are described in the following sections.

Binary and Hexadecimal views display the bitstream for the structures displayed
when you accessed the Binary or Hexadecimal view.

NOTE. The Binary and Hexadecimal views accessed from the Picture and the
Slice views are identical. Also, the Hexadecimal view of the sequence structure
displays the same information that is displayed when you double-click the large
User data rectangle in the Sequence view window.

To display the Binary and Hexadecimal views for a specific video elementary
stream structure, use the following procedure:

1. Navigate to the interpreted view window for the structure you want to
display.

2. Select the Add View icon on the Upper toolbar (see page 2—3), and then
selectBinary or Hexadecimalfrom the submenu. (Alternatively, seléad
View from the Window menu, and then selBatary or Hexadecimalfrom
the submenu.)

The information displayed is the bitstream of the item indicated in the top line of
the view window. The following illustration shows the bitstream of the third
item out of 750 in binary format.

Eif Picture View > doncarlo.vid :2

Item 3 /7 758
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The analysis functions of the MPEG Video Stream AnalyzerAseéy/zing

Video Elementary Streanbeginning on page 3-11) and the Edit toolbar are
available from both the Binary and Hexadecimal views. Only syntactic analyses
can be performed from the Binary or Hexadecimal views, and the Next error
button (and thé&lext error menu selection) searches for and displays only
syntactic errors.

Decoded Picture View  The small I-picture displayed in the Main view is decoded using only the DC
coefficients. You can display the picture with all of the coefficients decoded
using one of the following methods:

®  From the Main view, double-click the small I-picture.

m  From the Main view, seleétdd View, and then seled@ecoded Picture
View from the submenu.

®  From the Main view, select the Add View button on the Upper toolbar (see
page 2-3), and then seléxcoded Picture Viewfrom the submenu.

NOTE. The decoded I-picture is independent from all analyses performed by the
MPEG Video Stream Analyzer. It is not a way to analyze the stream, but provides
you with visual feedback about the video stream. If a problem occurs during the
decoding process, the I-picture is not decoded.
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Analyzing Video Elementary Streams
The MPEG Video Stream Analyzer can check for both syntactic and semantic

errors as described in this section.

Syntactic Analysis  Syntactic analysis checks the validity of the values for each structure indicated in
Table 3-2 against the syntax described in the appropriate paragraph from the
standard.

Table 3-2: Syntactic analysis tests

Interpreted View | Structure ISO/IEC 13818-2 paragraph
Sequence Sequence header 6.2.2.1
Sequence extension 6.2.2.3
Sequence display extension 6.2.2.4
Sequence scalable extension 6.2.2.5
Group of Pictures | Group of pictures header 6.2.2.6
Picture/Slice Picture header 6.2.3
Picture coding extension 6.2.3.1
Quant matrix extension 6.2.3.2
Picture display extension 6.2.3.3
Picture temporal scalable extension | 6.2.3.4
Picture spatial scalable extension 6.2.3.5
Copyright extension 6.2.3.6
Picture data 6.2.3.7
Slice 6.2.4

The MPEG Video Stream Analyzer does not perform a syntactic analysis on the
following MPEG-2 structures:

m  Macroblock (6.2.5)

m  Macroblock modes (6.2.5.1)
m  Motion vectors (6.2.5.2)

m  Motion vector (6.2.5.2.1)

m  Coded block pattern (6.2.5.3)
m  Block (6.2.6)
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You can perform syntactic analyses on a specific video stream structure, or on
the entire video stream, using the following procedure:

1. Display the interpreted view window of the syntax you want to check. (If
you want to check all of the sequence, GOP, and picture structures, perform
the syntax analyses from the Main view window.)

2. SelectSyntactic from the Analysis menu. The view window changes and
looks similar to the following illustration. Press tBsckey to stop the

process.
Main view -> doncarlo.vid [_ (O] =]
Tem SH 1/1  Ttem GOP 39768 B

Syntactic analyvsis...
Pres=s escape to abort.

4] | M 4

3. If the analysis finds errors in the video stream syntax, the following message
box is displayed. Each line represents an error at the location indicated
(structure, item, and field).

%’Synlaclic analysis == E3
GOP - item #1 - Field: Marker bit -> Must be setto 1.

'GOP - item #2 - Field: Marker bit -> Must he setto 1.
GOP - item #3 - Field: Marker bit -> Must be setto 1.

CON oo HA Cinld: hdoskos hit % kdaod ho oot 4o 1
‘ ]
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4. To view the error, double-click a message line. The interpreted view
containing the field in error is displayed with the value in error shown in red.

B Syntactic analysis o =] 3

GOP - item #1 - Field: Marker bit -> Must be setto 1.
GOP - item #2 - Field: Marker bit -> Must be setto 1.

GOD - itam #3_Ciald: kdarkar hit 5 kdict ha cat to 1
[ Emup of pictures ¥iew -> doncarlo. vid

Group of pictures Ttem 2

Group Dirop Time | |Tine code| [Marker||Time code| Tine code|| Closed | |Broke

start code| frame flag| | code irtes it seconds || pictures zop linke
hours

L2 L o JLo J[ o Jloff o J[ o Jfollo

You can perform syntactic analyses on multiple structures or multiple elementary
streams at the same time.

NOTE. If you perform a syntactic analysis on a stream that you opened as a
Video Streanfile type, the syntax analysis begins on the structures located after
the first sequence header. If you perform a syntactic analysis on a stream you
opened as &equence, GORyr Pictures documentéle type, the analyses are
performed on all of the items for the video stream.

MPEG Video Stream Analyzer User Manual 3-13



Reference

Semantic Analysis  Semantic analyses checks the structure of the MPEG video stream, rather than
the values of the fields. Semantic analyses can be performed only when the Main
view is the active view window.

Table 3-3 describes the analyses performed when you conduct a semantic
analysis of the video stream. The paragraph numbers indicate the paragraph or
paragraphs of the standard upon which the tests are based.

Table 3-3: Semantic analysis tests

ISO/IEC 13818-2

Structure paragraph(s) Description
Sequence 6.1.1.6 If there are repeated sequence headers, all of the data
header elements shall have the same values as in the first

sequence header (with the exception of those defining
the quantization matrixes: load_intra_quantiser_matrix,
load_non_intra_quantiser_matrix, and optionally
intra_quantiser_matrix and non_intra_quantiser_matrix).

In the case that an interlaced frame is coded as two
separate field pictures, a repeat sequence header shall
not precede the second of these two field pictures.

Sequence 6.3.1 Sequence_extension() shall only occur immediately

extension following a sequence_header().
6.1.1.6

If the first sequence_header() of a sequence is followed
by a sequence_extension(), then all subsequent
occurrences of sequence_header() shall also be
immediately followed by a sequence_extension().

All of the data elements in the sequence_extension() that
follow a repeated sequence_header() shall have the same
values as in the first sequence_extension().

Sequence_extension() shall not immediately precede a
sequence_end_code.

Sequence 6.1.1.6 If a sequence_display_extension() occurs after the first

display sequence_header(), then all subsequent sequence

extension headers shall be followed by sequence_display_exten-
sion().

All data elements of a repeated
sequence_display_extension() must be the same as in the
first sequence_display_extension().

Conversely, if no sequence_display_extension() occurs
between the first sequence_header() and the first
picture_header(), then sequence_display_extension()
shall not occur in the bitstream.

3-14 MPEG Video Stream Analyzer User Manual



Reference

Table 3-3: Semantic analysis tests (cont.)

ISO/IEC 13818-2

Description

Structure paragraph(s)
Sequence 6.1.1.6
scalable

extension

If a sequence_scalable_extension() occurs after the first
sequence_header(), then all subsequent sequence
headers shall be followed by
sequence_scalable_extension().

All data elements of a repeated
sequence_scalable_extension must be the same as the
first sequence_scalable_extension().

Conversely, if no sequence_scalable_extension() occurs
between the first sequence_header() and the first
picture_header(), then sequence_scalable_extension()
shall not occur in the bitstream.

Picture header |6.3.1
6.1.1.11
6.3.9

The first coded frame following a
group_of_pictures_header() shall be a coded I-frame.

The first coded frame after a sequence header shall not
be a B-frame.

When a frame is coded as two fields, then temporal_refer-
ence in the picture header of both fields is the same.

Picture coding | 6.3.1
extension 6.3.10
6.1.14.1
6.3.5

picture_coding_extension() shall only occur immediately
following a picture_header().

If sequence_extension() occurs in the bitstream, then
each picture_header() shall be followed immediately by a
picture_coding_extension().

When a frame is encoded in the form of two field pictures,
both fields must be of the same picture_coding_type,
except when the first encoded field is an I-picture.

When a frame is encoded in the form of two field pictures,
if the first encoded field is an I-picture, the second may be
either an I-picture or a P-picture.

The first encoded field of a frame may be a top field or a
bottom field, and the next field must be of opposite parity.

If progressive_sequence is set to 1, the coded video
sequence shall contain only progressive frames pictures.

Picture display |6.3.12
extension

A picture_display_extension() shall not occur unless a
sequence_display_extension() followed the previous
sequence_header().
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3-16

Use the following procedure to perform a semantic analysis of the video stream:
1. Navigate to the Main view window for the video stream you want to analyze.

2. SelectSemanticfrom the Analysis menu. The view window will change
and look similar to the following illustration. Press st key to stop the
process.

Main view -> vertmire. vid

Tem SH 25  Ttem GOP 50 B

Semantic analysis...
Press escape to abort.

3. If the analysis finds semantic errors, a message box similar to the following
illustration is displayed.

@’Message for Main view -> vertmire.mpg
SEQ - item #3 - Field: -> A repeated SH shall have the same values as in the first SH.

SEQ - item #5 - Field: -> A repeated S5H shall have the same values as in the first SH.

1 | I

4. To view an error, double-click a message line. The interpreted view
displaying the structure in error is displayed as shown in the following
illustration. For semantic analyses, the errors are not indicated in red.
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=¥ Message for Main view -> vertmire.mpg = O] =]

SEQ - item #3 - Field: -> A repeated SH shall have the same values as in the first SH.
SEQ - item #b - Field: -> A repeated SH shall have the same values as in the first SH.

%% Sequence View -> vertmire.mpg

E
Sequence ||Honzontal || Vertical | [Aspect ratio| | Frame ||Bitrate | |Marker|| Wby buffer
header code| | size value || size value | | mformation | [rate code || walue bat size walue
0x1B3 || ox2co |[ ox240 || o2 || o0x3 lows1as|| ozt || o0xe9

Extension | [Extension start] | Profile and | [Progressive| [ Chroma || Horzontal | [Vertical size| | E

start code | |code identifier level sequence || format sizE extension ||ex

- ndication extension

= [oxB5 [ oxt ][ omis |[ ow0 [ o= |[ o0 ][ ox0 [
— 30— A b3 — ] — (—v
P —— | .

You can perform semantic analyses on multiple elementary streams at once.

Automatic Analysis ~ When you selecAutomatic from the Analysis menu, the MPEG Video Stream
Analyzer can perform any combination of Syntactic and Semantic analyses.
Indicate which analyses you want performed by selecting or deselecting them in
the Options for automatic analysisdialog box.

To specify how the analyzer performs automatic analyses, use the following
procedure:

1. SelectAutomatic Analysis from the Options menu.

2. Select any combination of the two options from the dialog box, and then
click OK.

To perform an automatic analysis, use the following procedure:
1. Navigate to the Main view window for the stream you want to analyze.
2. SelectAutomatic from the Analysis menu.

3. The message box shown in the following illustration is displayed while the
type(s) of analyses that you selected in the previous procedure are
performed.
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& Automatic analysiz for doncarlo.vid [_ (O] =]
Status Result
Syntactic Running...
Semantic

SH 1 GOP 53

The title bar indicates the file on which the analyses are being performed.
The sequence headers and GOPs being analyzed are indicated in the bottom

portion of the Automatic Analysis window. Select the command button at
the bottom of the window to stop the analyses.

4. When the analyses are complete, the results column indicates whether any
syntactic and/or semantic errors were found.

& Automatic analysis for doncarlo.vid

Status Result
Syntactic Completed Errors
Semantic Completed 0K

5. Double-click a redrror to display an error message window.

6. To view an error, double-click a message line in the error message window.
The interpreted view containing the field in error is displayed. If the error is

a syntax error, the value in error is shown in red. Semantic errors are not
shown in red.
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Configuration Reference

Numerical Base

Font

Interpretation

Using the selections from the Options menu, you can configure how the current
MPEG Video Stream Analyzer session displays information, and you can save
and load configuration files.

You can change the numerical base displayed in the small rectangles of the
interpreted view using one of the following methods:

m  SelectBasefrom the Options menu, and then sel@etimal or Hexade-
cimal.

m  Press thé&2 function key to toggle the numerical base settings.

NOTE. Even though you can display information in either decimal or hexade-
cimal, you can enter values only in decimal base.

When you start a new MPEG Video Stream Analyzer session, the analyzer uses
the base displayed the last time you exited the application.

You can change the font displayed in the view windows using the Font dialog
box. To display the Font dialog box, seleont from the Options menu. Some
view windows use a fixed font and are not affected by font choices.

When you start a new MPEG Audio Stream Analyzer session, the analyzer uses
the font displayed the last time you exited the application.

You can display the length or the position of a parameter in the bitstream. When
enabled, this information is displayed below the small rectangles in interpreted
view windows. You determine which type of information, if any, is displayed
using the following procedure:

1. Selectinterpretation from the Options menu, and then select one of the
following options:

m  Positionindicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

®  Length is the length in bits of the parameter.

2. To disable the display of this information, deselect both options (this is
the default configuration).

When you start a new MPEG Video Stream Analyzer session, the analyzer
uses the configuration used the last time the analyzer was exited.
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Directories  The Default Directories dialog box accessed by this menu selection allows you
to indicate what directory the MPEG Video Stream Analyzer should default to
when writing and loading message and configuration files.

Default directones

Mezzage directory:

LConfiguration Directony:
IE:\MTS2DD\VIDED

oK I Cancel

Include the full path to each directory.

Configuration Files  There are three Options menu selections you can use to save and load configura-
tion files. The configuration files determine the following states for the current
analyzer session (default settings are indicated in parentheses):

Base (Decimal)

Font (9pt, Times New Roman)

Interpretation (No interpretation options selected)
Main view type (Standard view)

Default message and configuration directories (path to your
MTS200\VIDEO directory)

Type of automatic analysis (Syntactic and Semantic analyses performed)

The analyzer uses the configuration that was current when you last exited the
application.

3-20
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Read Configuration. This menu selection displays a dialog from which you can
load a previously saved configuration file (an .acf file) into the current analyzer

session. Use standard Windows NT Open dialog box methods to open and load a
configuration file.

Read Configuration 7]
File name: Folders: oK
Im c:vmits2008video -

Cancel
wid. acf :I [E=r b ;I _l
wid2 acf B MT5200
B= vIDED
1528
£ B8
Save file as lype: Dirives:
Config. file j I Hc j Metwork... |

Save Configuration. This menu selection displays a dialog box from which you
can save the current configuration settings to a new configuration file (an .acf

file). Use standard Windows NT Save as dialog box methods to save a new
configuration file.

Save Configuration HE
File name: Folders: oK
Im chmts200%video -

Cancel |
wid. acf =] =t =]
wid2. ack (= MTS200
= vIDED
£ 525
£ 625

Save file az type: Dirives:

Config. file j I =1 j Metwark. .. |

Set Default Configuration. This menu selection displays a dialog box from which

you can change the current configuration selections to the default settings
described on page 3-20.

MPEG Video Stream Analyzer User Manual 3-21



Reference

3-22 MPEG Video Stream Analyzer User Manual



-/ |
Appendix






./ |
Appendix A: Save Video Stream Option Examples

The following scenarios will help explain how parts of a video stream are saved
using the Save Video Stream dialog box options. For each of the examples in
this section, refer to the following description of a hypothetical video stream:

Sequence headers (5) Group of pictures (5) Pictures (84)
SH1 GOP1 P1 through P12
SH2 GOP2 P13 through P24
SH3 P25 through P36
SH4 P37 through P48
GOP3 P49 through P60
GOP4 P61 through P72
SH5 GOP5 P73 through P84

Keep in mind the rules used by the MPEG Video Stream Analyzer when
determining which parts of the video stream to save:

m  Video stream files can be saved only from the Main view window.

®  Only video streams with at least one sequence header can be saved.

®  Only those sequence headers, GOPs, and pictures after the first sequence

header can be saved to a new video elementary stream file.

m [f a sequence header immediately precedes a GOP that is to be saved, the

sequence header is automatically saved.

m  The saved portion of the stream begins with the &D&wing the picture

you indicate in thé&rom picture text box and includes the G@Pthe
picture you indicate in thi picture text box, with the following two

exceptions:

If the picture indicated in thérom picture text box is the first picture in
any GOP, then the stream is saved beginning with the GOP of the

picture, not the following GOP.

If the indicated pictures are in the same GOP, then that GOP is saved.
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Scenario A

Scenario B

Scenario C

Scenario D

In the Save as dialog box, you selemm GOP 2to GOP 2. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

SH2 GOP2 P13 through P24
SH3 P25 through P36
SH4 P37 through P48

In the Save as dialog box, you seleam GOP 2 to GOP 3. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

SH2 GOP2 P13 through P24

SH3 P25 through P36

SH4 P37 through P48
GOP3 P49 through P60

In the Save as dialog box, you seleadm GOP 3 to GOP 4. The saved portion
of the stream will then include the following elements:

Sequence headers Group of pictures Pictures
GOP3 P49 through P60
GOP4 P61 through P72

In the Save as dialog box, you selemm picture 30to picture 70. The saved
portion of the stream will then include the following elements:

Sequence headers Group of pictures Pictures
GOP3 P49 through P60
GOP4 P61 through P72

P30 belongs to GOP2, but it is not the first picture of the GOP. Therefore, the
analyzer begins saving with GOP3.

Because P70 is part of GOP4, the analyzer saves all of GOP4.
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Scenario E

Scenario F

In the Save as dialog box, you selemm picture 13to picture 70. The saved
portion of the stream will then include the following elements:

Sequence headers Group of pictures Pictures

SH2 GOP2 P13 through P24

SH3 P25 through P36

SH4 P37 through P48
GOP3 P49 through P60
GOP4 P61 through P72

P13 is the first picture of the GOP2, so the analyzer begins saving with GOP2.

As in the previous example, the analyzer saves all of GOP4.

In the Save as dialog box, you seleam picture 50to picture 57. The saved
portion of the stream will then include the following elements:

Sequence headers

Group of pictures

Pictures

GOP3

P49 through P60

P50 and P57 belong to the same GOP, so the entire GOP (GOP 3) is saved.
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A

About the MPEG Video Stream Analyzer, 1-1
Add view

menu selection, 2—21

options, 2-12
Analyzer views, 2—7
Analyzing video streams, overview, 2—17
Application window, 2—2
Arrange icons, menu selection, 2—21
Automatic analysis

menu selection, 2-20

procedure, 3-17

set up, 2-20

B

Base

menu selection, 2—20

procedure for changing, 3—19
Binary view

displaying, 3-9

overview, 2-11
Bit stream values, interpreting, 3—3
Buttons

edit toolbar, 2—4

slice toolbar, 3-8

upper toolbar, 2—-3

C

Cascade, menu selection, 2-21
Change numerical base, 3-19
Close all, menu selection, 2-21
Close view, menu selection, 2-21
Colored rectangles, 3—2
Common view window elements, 2-5
Configuration, read, save, and set default, 3—-20
Contact numbers, Tektronix, iv
Contents, menu selection, 2-21
Cut Down/Blow up Main View
F3 function key accelerator, 2-9
menu selection, 2-20
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D

Decimal and Hexadecimal base, 3—19
Decoded picture view, 2-11, 3-10
Default configuration file, 3—20

Deferred-Time Analyzer, opening video elementary

streams using, 2—-14

Description of common window elements, 2-5

Directories, Option menu selection, 3—20
Displaying items using the Edit toolbar, 2—4
Displaying MPEG descriptions, 3—2

E

Edit toolbar, 2—4
Elementary video streams
analyzing, 2-17
opening, 2-13
printing, 2-18
saving, 2-15

Examples showing how to save video streams, A-1

Exit, menu selection, 2-19
Exiting the application, 2—19

F

First, menu selection, 2—-19
First time operation, 1-2
Font
menu selection, 2-20
setting, 3—-19
Functional overview, 2—-2

G

Go to, menu selection, 2-19

GOP document, opening a file as, 2-14
Gray rectangles, 3-2

Group of pictures (GOP) view, 3-5

H

Hexadecimal and Decimal base, 3—-19
Hexadecimal view

displaying, 3-9

overview, 2-11
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| picture, 2-11
decoding, 3-10
Icons

edit toolbar, 2—4

upper toolbar, 2—-3

Video Stream Analyzer, 2-1
Interpretation, menu selection, 2—20
Interpreted views, 2-9, 3-1

common window elements, 3—-2

Group of Pictures (GOP) view, 3-5

Picture view, 3-6

printing, 2-18

Sequence view, 3—4

Slice view, 3-8
Interpreting bit stream values, 3—-3
Item indicator, 2—6

L

Last, menu selection, 2—-19
Length/Position indicator, 3—3
interpreted views, 2—-11
setting, 3—-19
Limitations, 1-2
List files of type, open dialog box selection, 2-14
List of open view windows, menu selections, 2-21
Load default configration, 3—21
Lower toolbar, 2—4

M

Main characteristics, menu selection, 2-20
Main Characteristics view, 2—7
Main View, menu selection, 2—-20
Main view, 2-8
detailed and less detailed option, 2—20
Main view elements, 2-9
Menu bar, 2-3
Menu Selections
Analysis menu, 2—20
Edit menu, 2-19
File menu, 2-19
Help menu, 2-21
Options menu, 2—-20
Selection menu, 2-20
Window menu, 2-21

Index-2

MPEG descriptions, displaying, 3—-2
MPEG elements analyzed

during a semantic analysis, 3—-14

during a syntactic analysis, 3—11
MPEG elements displayed

in the GOP view, 3-5

in the Picture and Slice views, 3-7

in the Sequence view, 3—4
MPEG-2 elements not analyzed, 3-11

N

Next, menu selection, 2—-19

Next error, menu selection, 2-19

Number of Items, menu selection, 2-19
Number of items, 2—6

Numerical base, procedure for changing, 3—-19

O

Open
from a transport stream, 2-14
menu selection, 2-19
using the Deferred-Time Analyzer, 2-14
video stream files, 2-13

Options menu
Automatic analysis selection, 3-17
Base selection, 3-19
Configuration selections, 3—20
Directories selection, 3-20
Font selection, 3-19
length or position indicator, 3—19

P

Page setup, printer setup, 2—19
Picture view, 3-6
Pictures document, opening a file as, 2-14
Position/Length indicator, 3-3
interpreted views, 2—-11
setting, 3-19
Previous, menu selection, 2-19
Print
menu selection, 2-19
procedure, 2-18
Print setup, menu selection, 2-19
Product description, 1-1
Product Support, contact numbers, iv
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Q

Quant matrix, displaying, 3-5
Quitting the application, 2-19

R

Read configuration, 3-21
menu selection, 2—20
Rectangles
in interpreted view windows, 2-10, 3-2
in Main view window, 2-9
shaded, 3-2

S

Save as, menu selection, 2-19
Save as examples, A-1
Save configuration, 3-21
menu selection, 2—-20
Saving video streams
examples, A-1
procedures, 2-15
Semantic analysis
menu selection, 2—20
MPEG elements checked during, 3—-14
overview, 2-18
procedure, 3-14
Sequence document, opening a file as, 2-14
Sequence view, 3—4
Service Support, contact numbers, iv
Set default configuration, 3-21
menu selection, 2—20
Shaded rectangles, 3-2
Slice toolbar, 3-8
Slice view, 3-8
Starting the application, 2—1
Status bar, 2—4
Syntactic analysis
menu selection, 2—20
MPEG elements checked during, 3—-11
overview, 2—17
procedure, 3-11
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T

Tektronix

MPEG Test System, iii

support contact numbers, iv
Tektronix MPEG Test System, 1-2
Tile, menu selection, 2-21
Title bar, 2-2
Toolbar

edit, 2-4

slice, 3-8

upper, 2-3

U

Upper toolbar, 2—-3

V

Video stream, opening a file as, 2-14
Video streams
analyzing, 2-17
opening, 2-13
printing, 2-18
saving, 2-15
View type, 2—6
View windows, 2—7
description, 2-5
types, 1-1
Views
adding, 2-12
Binary and Hexadecimal, 2-11, 3-9
Decoded picture, 2-11, 3-10
Group of pictures (GOP), 3-5
Interpreted views, 2—9
Less detailed Main view, 2—9
Main, 2-8
Main characteristics, 2—7
Picture, 3-6
Sequence, 3—4
Slice, 3-8

W

Window, application, 2—2
Window elements, 2-5
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